#1 20 Jun 2013 - 15:43:40

Donatien
Membre
Inscription : 25 Feb 2013
Messages : 16

réinstallation de TRIADE 1.7.a sous windows 7

Bonjour à vous,
en effet, j'ai personnalisé TRIADE 1.7.a c'est à dire j'ai fais quelques modifications dans le code source. Mon application tournait sans problème sauf que j'ai eu à refaire mon système d'exploitation. J'ai copié mon dossier TRIADEV et ma base de données Triade. après réinstallation du système et installation de apach2triad 1.5.4, j'ai collé le dossier Triadev dans C:\apache2triad\htdocs et la base de données Triade dans C:\apache2triad\mysql\data. quand je lance l'application, je ne parviens pas à visualer les interfaces de connexion par exemple. c'est juste la page d'accueil qui s'affiche.
Pouvez-vous me donner la conduite à tenir pour faire fonctionner normalement mon application?
merci d'avance.

Hors ligne

#2 21 Jun 2013 - 10:53:20

administrateur
Administrator
Inscription : 09 Sep 2012
Messages : 478

Re : réinstallation de TRIADE 1.7.a sous windows 7

Bonjour,

Vous devez tout d'abord, installer triade en version 1.7.a , comme si c'etait la premier fois.

Une fois l'installation effectué, si vous avez installé les patchs pour la 1.7.a   le faire aussi pour être au même niveau que votre sauvegarde.

Ensuite, restaurer la base de donnée Triade,

Derniere étape effectué une vérification, via le module vérification du compte administrateur triade.

Hors ligne

#3 09 Jul 2016 - 23:11:52

Donatien
Membre
Inscription : 25 Feb 2013
Messages : 16

Re : réinstallation de TRIADE 1.7.a sous windows 7

Bonsoir,
J'ai un problème avec l'installation de TRIADE 1.7.a.
Pour commencer, j'utilise le serveur WampServer Version 2.5.
J'ai crée la base de données triade et j'ai installé le fichier triade-full.exe dans triadev1 dans le dossier www de wamp.
les champs renseignés lors de l'installation sont les suivantes:
Choix de la base :Mysql   
Type du serveur : Wampserver   
Host de la base :    localhost
Nom de la base :    triade
Login d'accès à la base : root
Mot de passe d'accès la base : "rien"   
Nom du répertoire racine :triadev1
Préfixe des tables :tria_
Type des tables :InnoDB

Lorsque je clique sur enregistrer, voici ce qui s'affiche:
CREATE TABLE tria_fichier( id INT NOT NULL AUTO_INCREMENT , titre varchar(30), fichier varchar(255), date date, TYPE varchar(20), PRIMARY KEY (id)) TYPE=MYISAM

Warning SQL
Problème d'accès à votre serveur SQL, pour corriger cliquez sur le bouton suivant: Réparer le requête SQL

DB Error: syntax error -2 CREATE TABLE tria_fichier( id INT NOT NULL AUTO_INCREMENT , titre varchar(30), fichier varchar(255), date date, TYPE varchar(20), PRIMARY KEY (id)) TYPE=MYISAM [nativecode=1064 ** Erreur de syntaxe près de 'TYPE=MYISAM' à la ligne 7]

lorsque je clique sur réparer la requête SQL, rien ne se passe.
Que dois-je faire?
Merci d'avance pour votre aide.

Hors ligne

#4 11 Jul 2016 - 13:43:22

administrateur
Administrator
Inscription : 09 Sep 2012
Messages : 478

Re : réinstallation de TRIADE 1.7.a sous windows 7

Bonjour,

Avez vous essayé de passer la requête qui pose problème directement dans phpMyAdmin dans une base quelconque afin de voir ce qu'il se passe.

Eric.

Hors ligne

#5 11 Jul 2016 - 15:41:50

Donatien
Membre
Inscription : 25 Feb 2013
Messages : 16

Re : réinstallation de TRIADE 1.7.a sous windows 7

Bonjour,
Merci beaucoup pour votre feed-back.
Lorsque j'exécute la requête: CREATE TABLE tria_fichier( id INT NOT NULL AUTO_INCREMENT , titre varchar(30), fichier varchar(255), date date, TYPE varchar(20), PRIMARY KEY (id)) TYPE=InnoDB

dans la base de données triade que l'ai crée, voici ce que j'obtiens:

Erreur
Requête SQL :
CREATE TABLE tria_fichier( id INT NOT NULL AUTO_INCREMENT , titre varchar(30), fichier varchar(255), date date, TYPE varchar(20), PRIMARY KEY (id)) TYPE=InnoDB
MySQL a répondu: Documentation

#1064 - Erreur de syntaxe près de 'TYPE=InnoDB' à la ligne 1

Hors ligne

#6 11 Jul 2016 - 15:47:19

Donatien
Membre
Inscription : 25 Feb 2013
Messages : 16

Re : réinstallation de TRIADE 1.7.a sous windows 7

Bonjour, je reviens encore pour une fois.
Lorsque je remplace la variable "TYPE" par "ENGINE", la requête s'éxécute mais sans renvoyé de veleur. J'obtiens ceci:

MySQL a retourné un résultat vide (aucune ligne). (Traitement en 0.0000 sec)

SELECT * FROM `tria_fichier`

Hors ligne

#7 11 Jul 2016 - 15:53:20

Donatien
Membre
Inscription : 25 Feb 2013
Messages : 16

Re : réinstallation de TRIADE 1.7.a sous windows 7

A noter que je n'arrive pas également à accéder au dossier triadev1 du site à partir de l'index de localhost. Je le fais uniquement en tapant l'url complet dans le navigateur ou en passant par My projects de wampserver.  Dans locahost, quand je clique sur le dossier triadev1, je suis redirigé vers une page internet qui affiche le messsage: Ce site est inaccessible.
l'url est: http://%20localhost/triadev1

Merci d'avance pour votre aide.

Hors ligne

#8 12 Jul 2016 - 10:23:31

administrateur
Administrator
Inscription : 09 Sep 2012
Messages : 478

Re : réinstallation de TRIADE 1.7.a sous windows 7

pourquoi avez vous un espace devant localhost (le %20 équivaut à l'espace)

Hors ligne

Pied de page des forums