#1 04 Apr 2013 - 13:51:04

boabashint
Membre
Inscription : 04 Apr 2013
Messages : 1

Installation sous Linux, PHP 5.4 (Magic Quotes supprimés)

J'ai fait une nouvelle installation de Triade sur un serveur Linux (Lubuntu 12.10) avec PHP 5.4 et MySQL. Une fois l'installation terminée, j'ai installé le patch 000-MD5. À partir de ce moment-là, quand j'essaye de naviguer dans le GUI je tombe sur des pages vides.

J'ai cherché dans le code et j'ai trouvé certains fichiers, par exemple

admin/librairie_php/mactu.php
librairie_php/mactu.php

qui contiennent des chaînes de caractères qui doivent visiblement être traitées avec Magic Quotes. Malheureusement PHP 5.4 a supprimé les Magic Quotes. Ces chaînes de caractères ne sont donc pas traités correctement. Et je pense que c'est la source de l'erreur (les pages vides).

J'ai tenté de réinstaller Triade en changeant le paramètre

PHPMAGICQUOTE

en

"non" ou "off" (j'ai essayé les deux) dans les fichiers de configuration. J'ai aussi essayé de changer cette option dans la page où sont affichés les paramètres. Mais j'ai toujours des pages vides.

Ma question est : Peut-on faire fonctionner Triade sans les Magic Quotes (en sachant que PHP 5.4, la dernière version, les a supprimés) ?

Merci d'avance.

Hors ligne

#2 04 Apr 2013 - 14:18:23

administrateur
Administrator
Inscription : 09 Sep 2012
Messages : 470

Re : Installation sous Linux, PHP 5.4 (Magic Quotes supprimés)

Bonjour,

En effet, nous n'avons pas validé la version php 5.4  la derniere version supporté est 5.3 pour le moment.
Nous finissons l'année scolaire et cet été une refonte du code sera fait pour etre compatible pour la version 5.4.

Thomas.

Hors ligne

#3 08 Nov 2013 - 13:05:49

aerologic
Membre
Inscription : 02 Nov 2013
Messages : 1

Re : Installation sous Linux, PHP 5.4 (Magic Quotes supprimés)

Bonjour,

Pour info à celui qui passerait à Debian 7, il est possible de réinstaller une version PHP 5.3 compatible avec le code actuel de Triade. Le même principe s'applique sous Ubuntu.

Info ici: downgrading to PHP 5.3 on Debian Wheezy (7.0)

Seul mystère que je n'ai pas compris, en cas de page blanche après la manipulation, il est nécessaire de supprimer les 3 fichiers suivants:

./mactu.php
./admin/librairie_php/mactu.php
./librairie_php/mactu.php

Ils seront régénérés automatiquement.

Cordialement,

Hors ligne

#4 20 Aug 2014 - 12:55:58

bmviso
Membre
Inscription : 10 Oct 2012
Messages : 1

Re : Installation sous Linux, PHP 5.4 (Magic Quotes supprimés)

Bonjour

a-t-on des nouvelles pour le passage à PHP5.4?

Bien cordialement

Bruno

administrateur a écrit :

Bonjour,

En effet, nous n'avons pas validé la version php 5.4  la derniere version supporté est 5.3 pour le moment.
Nous finissons l'année scolaire et cet été une refonte du code sera fait pour etre compatible pour la version 5.4.

Thomas.

Hors ligne

#5 20 Aug 2014 - 14:52:36

administrateur
Administrator
Inscription : 09 Sep 2012
Messages : 470

Re : Installation sous Linux, PHP 5.4 (Magic Quotes supprimés)

Oui :-)
Nous avons une version 1.9-beta en cours de test avec la prise en compte ou non des magic_quote afin d etre compatible 5.3 et 5.4

Cette version sera dispo courant septembre en version beta pour ceux qui souhaite tester aussi.


Eric.

Hors ligne

Pied de page des forums